Data Dashboard not displaying usage analytics
Resolved
Jun 05 at 02:31pm BST
The issue with Data Dashboard not showing usage analytics is now resolved. If you continue to see issues please log out and back in, clear your cache and reach out to support@texthelp.com if things continue.
Affected services
Dashboard
Created
Jun 04 at 03:39pm BST
We've identified an issue with Data Dashboard, which may display a We are currently processing new data and will be back shortly. message and not show usage analytics. The development team is actively working on a fix for this issue. We're expecting everything to be back to normal by tomorrow (6/5/2025) .
Please go to status.texthelp.com and click "Get Updates" to be notified when this is resolved if you are experiencing this issue.
Affected services
Dashboard